Les meilleures sources algorithmesConsultez toutes les sources

Nombre d'auteurs : 1, nombre de sources : 15, dernière mise à jour : 4 janvier 2007 

 
OuvrirSommaireAlgorithmes numériques

Entrée:

 
Sélectionnez

x : nombre entier ou réel.
n : nombre entier positif.

Sortie:

 
Sélectionnez

x à la puissance n : x^n

Pseudo-Code :

 
Sélectionnez

EXPONENTIATION( x , n )
DEBUT
SI n = 0 ALORS
    RENVOYER 1
SINON 
    SI n = 1 ALORS
        RENVOYER x
    SINON
	    tmp = EXPONENTIATION( x , n/2 )
        SI n est pair ALORS
            RENVOYER tmp * tmp
        SINON
            RENVOYER x * tmp * tmp
        FIN SI
    FIN SI
FIN SI
FIN

Complexité :

 
Sélectionnez

O( log n )
Créé le 17 août 2006  par Romuald Perrot

Entrée:

 
Sélectionnez

a et b, deux entiers

Sortie:

 
Sélectionnez

Le pgcd de a et de b

Pseudo-Code :

 
Sélectionnez

PGCD( a , b ) 
    SI b est égal à 0 ALORS
	    RENVOYER a 
	SINON
	    RENVOYER PGCD( b , a mod b ) 
	FIN SI

Complexité :

 
Sélectionnez

0(n) (où n est la taille du plus grand nombre en bits )
Créé le 17 décembre 2006  par Romuald Perrot
  

Les sources présentées sur cette page sont libres de droits et vous pouvez les utiliser à votre convenance. Par contre, la page de présentation constitue une œuvre intellectuelle protégée par les droits d'auteur. Copyright © 2006 Developpez Developpez LLC. Tous droits réservés Developpez LLC. Aucune reproduction, même partielle, ne peut être faite de ce site et de l'ensemble de son contenu : textes, documents et images sans l'autorisation expresse de Developpez LLC. Sinon vous encourez selon la loi jusqu'à trois ans de prison et jusqu'à 300 000 € de dommages et intérêts.